Решение домашних заданий

Дано а. не пользуясь никакими другими арифметическими операциями кроме умножения получить а^9 за 4 опереции

1 января 0001 / Информатика / Комментарии: 0

дано а.не пользуясь никакими другими арифметическими опперациями кроме умножения получить а^9 за 4 оппереции

  • Sqr(a)*sqr(a)*sqr(a)*sqr(a)*a
  • Нам такое на КуМИРе задавали, если Вам тоже, то…
    алг
        нач

            цел a, b 
            ввод a  
            b := a * a;  
            b := b * b;  
            b := b * b;  
            b := a * b;  
            вывод b
        кон

    …или на Pascal:
    var a, b: integer;
    begin
         readln(a);
         b := a * a;
         b := b * b;
         b := b * b;
         b := a * b;
         writeln(b);
    end.

Добавить комментарий